Project Analyzer reports - Options

Reports

Report formats

Project Analyzer supports several report formats. You can get the reports to the display, the printer or a file for your favorite word processor, file viewer, web browser or spreadsheet application.

To select the report format, open the Report options dropdown in the toolbar. You can also use the Options|Report options menu.

Display Display report
Display report is the default. The output goes to a Display window where you can read it, copy it to the clipboard, save it to a file or print it. Available save file formats in this window are .rtf, .pdf and .txt. Additional file formats are available via the Report to a file option.
Note: PDF files saved through the Display window use less rich formatting that reports saved directly to a PDF file (see below).
Printer Print report
Print reports directly to the printer without preview. Print-outs are similar to PDF reports. Use the Print setup command in the File menu to choose a different printer and to define page size, orientation and margins.
Report to a file
You can also save directly to a file in several file formats. By default, Project Analyzer creates new reports into a temporary directory. To save to another location, select Save next report as... in the menu Options|Report options.
FormatViewerNotes
HTML HTML Any Web browser HTML generated is compatible with any browser, such as Internet Explorer, Firefox and Chrome.
RTF RTF MS Word or WordPad Editable report. Optimized for MS Word, but readable with other word processors too. Page size is either A4, Legal or Letter according to your Windows default page size.
PDF PDF Adobe Reader 4.0 and later This option creates PDF optimized reports. You could also use the Display report window, but this option uses an improved formatting. Page size is the same as the current printer page size (defined in Print setup).
TXT Text Notepad or WordPad This option creates plain-text reports.
CSV CSV Microsoft Excel This special format is for exporting tabular data to a spreadsheet such as Excel. CSV is not suitable for reports that have no tables or columns.
MHT MHT Internet Explorer 5.0 and later Single-file web archive. Especially suitable for saving Project Printer output in a single file.

Configure reports dialog

This dialog, available through the Options|Report options menu, allows you to configure viewers, the report directory and the report footer.

Viewer
Project Analyzer lauches a viewer when a report is complete. By default, the Windows file associations are used to lauch the viewer. You can also configure a specific application as the viewer. Write your own command line in the appropriate field. Enclose the application name and path in quotation marks, as well as the file name parameter which is "%1".

Example: "c:\program files\viewer.exe" "%1"

Report directory
This is the directory where new report files will be put. The default is under the system Temp directory. Press the Reset button to use the default directory.
Report footer
Every report has a standard line at the end. This is where you can configure it. Write any string here. You can also use the following special macros.
%d Current date.
%n Name of your project, project group or solution.
%v Version of your project, as set in VB project options. Not available in all analyses, in which case %v will be empty.
%p Project Analyzer v1.2.3 (current version number).
The default footer is %p (%d) %n %v, which translates into Project Analyzer v1.2.3 (date) myproject v1.2.3.

Font options for reports

You can pick fonts for your reports. Open Font options in the Options menu. Exception: HTML reports use their on font options, see below.

If you need reports that look good on other computers too, use a font that is available on your target machines. Fonts are not embedded in the reports.

PDF note. Support for complex scripts, where character form depends on context, is limited. For proper Hebrew support, select Hebrew as the font script. For proper Arabic support, select an Arabic script font that contains glyphs for all Arabic presentation forms (Unicode FB50 to FEFF). Example of a working Arabic font: Code2000.

HTML options

HTML reports have additional configuration options. Select Options|HTML options. You can choose from 3 types of configuration settings. You can either utilize the built-in formatting options or configure your own formatting with the help of a CSS file.

1. Built-in options

This group of settings allows quick and simple configuration of fonts and colors.

The settings will actually be stored within the report HTML file in a style block coded in the CSS language. The good news is, you can fine-tune the settings. You only need to know how to write simple CSS. Search the web for CSS tutorials if you wish to learn it.

2. Embed CSS from file

This option allows you to embed your own customized CSS file to a style block in each HTML report. Your reports will be self-contained in that the data and the formatting are in just one file.

3. Link to CSS file

This option allows you to link your own CSS file to each HTML report. This way you keep the formatting in one file. When you need to modify the formatting, you don't need to regenerate the reports. Pick an existing CSS file or write a URL in the textbox. What you write in the textbox will get to the HTML files as such. The URL should point to an existing CSS file that is available on the reader's machine or online so that readers of your reports will be able to view them with your formatting.

Customizing your CSS file

The best way to get started writing your own CSS for options 2 and 3 above is this: Click the button named "CSS to Clipboard", open your text editor (Notepad will do) and press Paste. Save the settings in a .css file. You now have a skeleton of a CSS file to fine-tune and embed or link to.

Reports

©Aivosto Oy - Project Analyzer Help Contents