Visustin version history

This is the list of changes and improvements in Visustin. For previous major version improvements see v8.0, v7.0, v6.0, v5.0, v4.0, v3.0 and v2.00.

Version 8

v8.03 February 2017

Fixed Print Preview: Changing the page orientation no longer resets other printer settings.
Fixed C#: Method declarations where return value is an array[].
Fixed Python: Certain statements mixing brackets and quotes led to hanging.

v8.02 November 2016

Fixed Save: Crash on a network drive.

v8.01 November 2016

Fixed VBScript: Colon-less syntax where no colon appears after Else or End If, even when another statement immediately follows. Else statement, Case Else statement, End If End If.

v8.0 November 2016

Visustin v8 is a language and compatibility update with a large number of enhancements to selected features and languages.

Major improvements

Word export update. Page size is adjusted to flow chart size. Export to DOC or DOCX file format.
Visio export update. Export to Visio 2016. Export to VSD or VSDX file format. Export "Flow chart alternative style". [Pro Edition]
Bulk flowchart update. HTML and MHT file formats rewritten. Improvements with .vjb files. Details below. [Pro Edition]

New languages

AutoIt v3
GW-BASIC (from partial to full support)
HTML and XML
PowerBASIC
RPG I-III, IV, **FREE

Updated languages

Major language updates
ActionScript: Support semicolon-less code.
JavaScript: Support semicolon-less code, object-oriented programming, prototype-based programming. Compatible with jQuery. Function and class expressions. Syntax up to ECMAScript 2016 (7th Edition, was 5.1).
PL/I: Auto-detect column format i.e. sequence numbers and printer control characters. No need to add *PROCESS MARGINS(2,72) to regular formatted code.

Language syntax updates
Support versions up to:
Batch files: Windows 7 (was WinXP). Support added: Cmd, Runas, Forfiles.
C: Standard C11 (was C99)
C++: Standard C++14 (was C++98), Visual C++ 2015 (was 2010)
C# 6.0 of Visual Studio 2015 (was C# 5.0 of VS2012). Support added: catch..when, interpolated strings.
Java 8 (was 7)
JSP 2.3 (was 2.1)
MASM: Visual Studio 2015 (was MASM v6.1). New instructions: SYSCALL, SYSRET, SYSENTER, SYSEXIT, XBEGIN, XABORT, XEND, RSM, JRCXZ, IRETQ.
NASM v2.12.02 (was v2.10.05). New instructions: SYSENTER, SYSEXIT, XBEGIN, XABORT, XEND, RSM, JRCXZ, IRETQ, INT3, UD2A, UD2B.
Perl 5.24.0 (was 5.16.0)
PHP 5.6 and 7.0 (was 5.4). Support added: finally, yield.
PureBasic 5.50 (was 4.61). Support added: Module, Macro, With, CompilerElseIf, ~".." strings.
Python 3.5.2 (was 3.2)
VB.NET 2015 (was 2012). Support added: multiline strings, interpolated strings, comments in multiline statements.
XSLT 2.0 (was 1.0). Support added: xsl:analyze-string, xsl:for-each-group, xsl:function.

Language changes verified, no update required

ABAP 751 (was 702)
LotusScript 9.0.1 (was 8.5.2)
MATLAB R2016b (was R2012b)
PL/SQL 12c (was 11g)
SAS 9.4 (was 9.3)

Language specific improvements

Improved fixed-format COBOL, Fortran, JCL, PL/I (and RPG): Edit menu commands Indent and Unindent (1 column) help deal with improperly formatted code. Ruler appears above code showing expected column format.
Improved C++: Support local classes and other types declared in a function.
Improved C/C++: Trigraph sequences are displayed the way they appear in the source code.
Improved C/C++/C#: Statements with curly braces, such as variable initialization, are displayed the way they appear in the source code.
Improved C++/C#: Constructor initializer shown more clearly.
Improved C++/C#/Java: Attributes and annotations show up in procedure or module declaration the way they appear in the source code.
Improved C++/C#/Java/JavaScript/ActionScript: Comments immediately preceding a procedure or a module show up above that procedure or module.
Improved C++/C#/Java/JSP/JavaScript/ActionScript/PHP: Multiline code blocks, such as data initializers, are displayed "as is" rather than being reformatted.
Improved C/C++/C#/Java/JSP/ActionScript: Support Unicode characters in procedure names.
Improved C/C++/C#/Java/JSP/JavaScript/ActionScript: Procedure name appears in Structure panel, PDF contents and Bulk filenames instead of full declaration.
Improved C#: catch (Exception e) catches all exceptions.
Improved C#: Auto-implemented properties do not create a separate, useless flow chart.
Improved C#: Multiline verbatim string literals @"…" are displayed the way they appear in the source code.
Improved C#: New symbol for yield return statement.
Improved GW-BASIC: Full support in language mode QuickBASIC, GW-BASIC. Previous version had partial support only.
Improved JavaScript/ActionScript: Display "var" statements.
Improved Perl: Display "use" statements in flow chart the normal way.
Improved PHP: Support deprecated tag <script language="php">. Display statements const and var.
Improved PL/SQL: Support for quoted identifiers.
Improved Python: Support async and yield. Unicode characters in function and class names. More file encodings, including cp858, cp65001 and latin9 (L9).
Improved QB: CHAIN and DATA statements.
Improved VB.NET: New symbol for Yield statement.

Improvements

General improvements

Improved Command line syntax dialog: Print command line syntax document. Includes programming language detection by file extension.
Improved File associations: No administrative privileges required. Settings are for current user, not whole machine.
Improved Print Preview: Display page size.
Improved Save: Suggest default filename based on source filename.
Improved look on high-density displays.
Improved online help: Full support for mobile devices.

Improvements with source code files
Improved code handling: Auto-replace non-breaking spaces with regular spaces in pasted code. Useful with HTML formatted code pasted from some email clients.
Improved file load: Auto-detect UTF8 files missing UTF8 header bytes (BOM). Feature enabled in Source encoding mode Automatic.
Improved file load: Auto-remove multiple ^Z characters from end-of-file. Useful with CP/M sources.
Improved file load: Auto-remove NULL characters from end-of-file. Useful with old sources.
Improved Font script: Automatic script detection when current Font script doesn't support foreign letters or other special characters found in code.

Bulk flowcharting improvements [Pro Edition]
Improved Bulk: HTML and MHT file formats rewritten, and their option "Split files by Structure" renamed as "Structure menu".
Improved Bulk: HTML with "Structure menu" produces 2 files per page (html and png). Previous versions produced 3 files per page.
Improved Bulk: Previous version file format Multi-image MHT with "Split files by Structure" has been replaced by Regular MHT with "Structure menu".
Improved Bulk: Regular MHT with "Structure menu" now creates a single MHT per source file, including flow charts of that file, plus a menu. Previous version created several MHT files per source file.
Improved Bulk: Multi-image MHT with "Structure menu" now creates just one MHT per job, including flow charts of all source files, plus a menu. Previous version created an MHT for each source file.
Improved Bulk jobs (.vjb load): Source filenames appear in their actual case. No longer forced to lowercase.
Improved Bulk jobs (.vjb load): Any line ending convention can appear in .vjb file. Previous versions required Windows CR+LF convention.
Improved Bulk jobs (.vjb load): New option Log=False disables creation of log file when running bulk jobs from the command line.

Bug fixes

Fixed Bulk: MHT files could be corrupt.
Fixed Editor: When saving as PDF, multiline text in a shape could squeeze to a single line. Now keeping multiline format.
Fixed Editor: Insert menu symbols appear in correct size relative to selected font size.
Fixed Print Preview: Pixels at bottom or right edge were not always visible.
Fixed Visio export: "End" box does not wrap the word "End".

Fixed ActionScript: package{} with no name.
Fixed C#: get|set accessor, unresolved goto case.
Fixed C++: __leave.
Fixed Fortran: FORALL statement without ENDFORALL.
Fixed MASM: COMMENT directive.
Fixed Perl: use Switch fallthrough and switch..else branch.
Fixed PureBasic: Procedure with return type such as Procedure.s and ProcedureDLL.s.
Fixed Python: Changed parser from case-insensitive to case-sensitive to avoid parse errors.
Fixed QB: RETURN line. Apostrophe and underscore in DATA statement.
Fixed T-SQL: Multiline string literals caused parser problems.
Fixed VB/QB: Leading zeros in line numbers.
Fixed VB/VB.NET/VBScript/QB: …: If..Then…:... Else where single-line If statement appears after another statement and Then is followed by a colon.
Fixed VB.NET: Exit Try statement executes Finally block before reaching End Try.

Removed and deprecated features

Removed Visio 2002 export. Oldest Visio version supported is 2003.
Removed save format: Save as PowerPoint file (PowerPoint export).
Removed save format: Save as .flw.png file. Loading is still possible.
Removed feature: Associate image files with Visustin.
Deprecated feature: Option to save a Visio VDX file has been hidden. To save as VDX, select VSD file format and type filename with extension .vdx.

Breaking changes

Bulk job files (.vjb) saved with Visustin v5–v7 may be incompatible with v8. Incompatibilities may exist with .vjb files defining an obsolete output format. Open your .vjb files with Visustin v8 to find out any incompatibilities. A message will tell the details. Saving a new .vjb file will fix the problems.

Compatibility notes

Supports Windows 10, Word 2016, Visio 2016.
Removed support for Visio 2002.

Version 7

v7.10 January 2015

Improved online help for mobile devices.
Fixed startup: Error #6 Overflow could occur for Far Eastern users.
Fixed Save PDF: Corrupted multipage PDF resulted if page size was exceptionally large.
Fixed Perl: Error message "Parse failure". Now attempt to auto-recover from failure.
Fixed Perl: Rare occasions where parser went out of sync.
Fixed Perl: eval{} statement.
Changed PL/SQL: A blank line does not terminate a statement. Statements are terminated by semicolon (;).
Changed PL/SQL: A terminating slash (/) or period (.) is visible in the chart.

v7.08 September 2014

Fixed startup: Potential critical errors.
Fixed Save PDF: Error handling.

v7.07 September 2014

Fixed Fortran: Error #9 with assignment statement END = expression.
Fixed Fortran: Error #91 with labeled DO ending in labeled END DO (extra END DO in code).
Fixed startup: Potential Error #6 Overflow due to non-standard keyboard.

v7.06 February 2014

Improved Editor: Straight and Round links in popup menu.
Improved Save PDF: Support more Unicode characters. Optimized PDF code.
Update: Windows 8.1 and VB2013 support confirmed.

v7.05 September 2013

Update: GW-BASIC is partially supported in QuickBASIC mode.
Improved: Selection of Other... encoding attempts to match font character set automatically.
Improved QB: Added support for RUN statement.
Fixed: Useless "Complete" dialog appeared when Visustin was restored from minimized state.
Fixed CJK: Editor & Visio layout problems with East Asian characters. Overlapping comments.
Fixed CJK: Editor word wrap bug with Japanese.
Fixed CJK: PDF truncated or misplaced CJK text, such as Japanese comments.
Fixed ABAP: Bug with CHECK statement in a loop.
Fixed ABAP: Bug with SUBMIT..AND RETURN with extra spaces after AND.
Fixed QB: Flow continues after DEF FN.
Fixed QB/VB: Bug with Rem statement after line number.
Fixed QB/VB: Bug with complex rare single-line If..Then..Else.

v7.04 March 2013

Update: Visio 2013 support.
Update: Word 2013 and PowerPoint 2013 support confirmed.

v7.03 February 2013

Update: Windows 8 support confirmed. Minor fixes and documentation update.

v7.02 January 2013

Fixed Save PDF: Error #11 Division by zero.
Fixed COBOL: SEARCH statement with AT END branch.
Fixed Fortran (fixed format): TAB line format supported also with files in LF line ending convention.

v7.01 November 2012

Fixed Bulk: Split files by Structure.

v7.0 November 2012

New features

New save format: PDF, multipage. Each procedure appears on its own PDF page. *
New option: Flow chart alternative style. Uses symbols closer to ISO standard flow charts.
New option: Display all code (distinct boxes). Each statement appears in its own box.
New option: Wrap lines. Control word wrapping in flow chart.
New option: Configure colors and labels. Change flow chart colors. Translate labels.

* The alternative is PDF, single page, which shows the entire file on one big page.

Notable improvements

High-density display support added. Example: Windows 7, font size "Larger 150%".
Visio export sends diagram to several Visio pages instead of a single big page.

New languages

ABAP
ActionScript 3.0 and MXML
Batch files (DOS/Windows)
Ruby
Shell script (sh, csh/tcsh, ksh, bash)
Tcl

Updated languages

Language syntax updates

Java 7 (was 3). Support added: try (with resources).
JavaScript: ECMAScript 5.1 (was 3).
Perl 5.16.0 (was 5.12.2). Support added: package.
PHP 5.4.6 (was 5.3.0). Support added: traits, Class::{expr}(), break 0; continue 0;
Visual Basic 2012 (was 2010). Support added: Async, Iterator, Yield.

Language changes verified, no update required
C# 5.0: Visual Studio 2012 (was C# 4.0 of VS2010)
ColdFusion 10 (was 9)
MatLab R2012b v8.0 (was v7.11)
NASM v2.10.05 (was v2.09.07)
PureBasic v4.61 (was v4.51)
REALbasic 2012r1 (was 2011)
SAS 9.3 (was 9.2)

More improvements

Improved Language menu. Favorite languages can be selected.
Improved support for ASCII control characters 0-31 and 127 in source code.
Improved command line: Language auto-detection. Command line options can be viewed through Help menu.
Improved drag & drop: Drop a file onto language dropdown to auto-detect language.
Improved display: Use smoother ClearType enabled font in dialogs. (Microsoft Sans Serif)
Improved Find: Find now searches in the Structure panel too.
Improved Save: Last used file format is persisted between sessions.
Improved Save PDF: Page numbers appear in a new style. Placed to avoid overwriting other symbols.
Improved Save PDF: Long text boxes appear more evenly filled.
Improved Save PDF and Editor: Improved appearance of some user edited shapes.
Improved robustness: Improved display of large charts.
Improved robustness: Improved splitting of large charts to parts.

Pro Edition improvements:
Improved Bulk: During execution, Visustin only displays a small status window, leaving more screen space for your other programs.
Improved Bulk: Write log file. Helps to detect errors.
Improved Bulk: Sort files alphabetically in mht and tiff archives.
Improved Bulk: .vjb file can be in UTF-8.
Improved Editor: Save optimized (low color) is enabled only when image can really be optimized.

Language specific improvements

Improved JSP: Automatic detection of source encoding from directive <%@page pageEncoding='..' contentType='..' %>.
Improved Java: Added support for @interface.
Improved C#, Java and JavaScript: Improved support for Unicode characters in identifiers such as statement labels.
Improved C#: Flow continues after yield return.

Bug fixes

Fixed Bulk Visio export: An invisible Visio.exe could stay running if bulk job failed.
Fixed Bulk HTML: Menu links generated with option "Split files by structure" now work with latest versions of Firefox and Chrome.
Fixed crash: A large switch/select block could cause a crash, especially on Windows 7.
Fixed errors with null characters found in source code.
Fixed Save PDF: A very large single-page PDF chart could be cut off at bottom or on the right.
Fixed Save PDF and Editor: Fixed self-links. Reduced shape overlap with diamonds and hexagons.
Fixed Java: Could get stuck with a single at sign @ not followed by a word.
Fixed Java: Error #28 with long /** */ javadoc comments.
Fixed JavaScript: Comment was ignored on a line in format /…// .
Fixed JSP: Parser failed between two slashes /…/ .

Removed features

Removed Windows 98 and ME compatibility. Visustin is no longer developed or tested for Win98 or WinME. It may still run.
Removed rare save formats: PPM, PGM, PBM, PCX, TGA.
Removed rare save formats: PNG with code, GIF with code, TIFF with code, TIFF archive with code.
While saving has been disabled, Visustin continues to load existing files in these formats.

Breaking changes

Bulk job files (.vjb) saved with Visustin v5 or v6 may be incompatible with v7. Incompatibilities may exist with .vjb files defining an obsolete output format. Open your .vjb files with Visustin v7 to find out any incompatibilities. A message will tell the details. Saving a new .vjb file will fix the problems.

Version 6

v6.15 September 2012

Fixed Save as PPM, PGM and PBM files.

v6.14 August 2012

Minor fixes and improvements.

v6.13 March 2012

Fixed bulk: Error #52 creating file, when processing C/C++ files with "Split files by Structure" checked.

v6.12 January 2012

Fixed bulk: Overly long filenames will be cut.

v6.11 August 2011

Fixed bulk: Job file (.vjb) filelist can exceed 32 KB when loaded.
Fixed bulk: Job file (.vjb) no longer runs "always on top".
Fixed bulk: Job file (.vjb) can be aborted by pressing Cancel or Ctrl+Break.
Fixed ColdFusion: Crash with <!------> comment containing only dashes.
Fixed XSLT: Crash with <!----> comment containing only dashes.

v6.10 March 2011

Updated language support

Matlab 7.11 (was 7.6)
NASM 2.09.07 (was 2.07)
Perl 5.12.2 (was 5.10.1)
Visual Basic 2010 (was 2008)

Other updates

Improved VB.NET: Interfaces and abstract methods.
Improved Save as PDF: Support characters outside the current codepage.
Improved parser speed on large code. Several languages.
Fixed NASM: Removed some empty shapes and comments.

v6.03 February 2011

Improved COBOL: Parser runs faster with large files.
Fixed COBOL: GO TO x, y DEPENDING ON z.
Fixed Delphi/Pascal: Removed hang with large files (10,000 lines).
Fixed VB.NET: #If/#ElseIf without Then
Fixed large charts: Error #372 in Word and PowerPoint export.
Fixed large charts: Error #28 Out of stack space.
Fixed large charts: Stuck creating layout during Visio export.
Fixed large charts: Resort to monochrome instead of printing "Failure" when out of memory.
Fixed tall charts: Split extremely tall charts. Extend horizontally instead.
Fixed PDF: Parts of some curved links were missing.
Fixed unnecessary reversing of self-links.

v6.02 August 2010

Fixed PL/SQL: Removed an occasional extra arrow from procedure start to end.

v6.01 May 2010

Fixed "semicolon" languages (C/C++): Out of stack space with many #pre-processor directives

v6.0 February 2010

Major improvements

Flowchart very large and complex files. Previous 3000-line limit has been lifted.
Flowchart individual procedures via new Structure panel.
Save PDF flow charts. Great way to zoom and view large charts.
Print at high resolution and quality. Optimized layout minimizes page break effects.
Bulk save each procedure into its own flow chart file.
Windows 7 support added.

New languages

JCL (MVS)
Matlab
PL/I
Rexx
SAS

JavaScript and VBScript: Scripts embedded on ASP pages (server-side scripting) and HTML pages (client-side scripting). New VBScript mode. (Previous versions only supported ASP pages with VBScript.)

Updated language support

Support updated to cover versions up to:
C++: Visual C++ 2008 (was 2005)
C# 3.0: Visual Studio 2008 (was VS2005 / C# 2.0)
ColdFusion 9.0 (was 8.0)
Java (& JSP): 3rd Edition of Language Specification (was 2nd)
LotusScript 8.5 (was 7)
NASM 2.07 (was 0.98.38)
Perl 5.10 (was 5.8.8)
PHP 5.3 (was 5.0)
PL/SQL: Oracle 11g (was 10g)
PowerBuilder 11.5 (was 10.5)
PureBasic 4.30 (was 4.00)
Python 3.1 (was 2.5)
RealBasic 2009r4 (was 2006)
Visual Basic 2008 (was 2005)

Language specific improvements

Improved C++: Visual C++/CLI
Improved C++: finally, for each, abstract|sealed class and struct, __if_exists, __if_not_exists
Improved C++ & C#: [attributes] displayed
Improved COBOL: Process much larger programs into meaningful flow charts.
Improved COBOL: Sections and paragraphs display as separate procedures according to actual PERFORM calls. Typically, an EXIT paragraph ends a procedure.
Improved NASM: sections/segments
Improved Perl: <<HEREDOC contents displayed
Improved Python: @decorators displayed in their own class or function
Improved VB: Err.Raise

More improvements

Improved Editor flow chart layout to minimize page break effects.
Improved Save as EMF and WMF image quality.
Improved Save as MHT to support larger images.
Improved export to Word and PowerPoint to use vector graphics.
Improved layout by replacing clusters (large boxes) with new symbols.
Improved support for Windows high-DPI modes ("Large Fonts" mode).
Improved display of Arabic letters.

Fixes

Fixed Perl: switch..case..else, given..when..default, goto &LABEL
Fixed Perl: eval block no longer creates an extra empty shape
Fixed PHP: Multiline strings
Fixed Python: #Comments in the middle of continued lines
Fixed RealBasic: Continue For x
Fixed RealBasic: Finally block will not execute after Return
Fixed VB.NET: <Assembly: attributes>

Removed features

Removed Save as multi-page GIF (multi-page TIFF provides better compatibility).
Removed Save as HTML with GIF (HTML with PNG works better).
Removed Save as PostScript (replaced by PDF).
Removed Save as DCX (rare format).
Removed Windows NT compatibility. Visustin is no longer developed or tested for NT4.

Breaking changes

Bulk job files (.vjb) saved with Visustin v5 may be incompatible with v6. Incompatibilities may exist with .vjb files defining an obsolete output format. Open your .vjb files with Visustin v6 to find out any incompatibilities. A message will tell the details. Saving a new .vjb file will fix the problems.

Version 5

v5.02 January 2009

Improved COBOL: Debugging lines are shown. Syntax: D in column 7 or >>D
Fixed COBOL: Crash with keyword NEXT in READ statement.
Fixed COBOL: Comment and line continuation characters (/*-) must appear in column 7 in free and variable format.
Fixed VB: Out of stack space with very long If..Then condition.
Fixed VB/ASP: Statements no longer break inside a time literal #12:34:56#.
Fixed LotusScript: With..End With.
Fixed Python: Multiline strings.
Fixed WinGraphviz.dll installation error in Windows Vista.
Fixed 'This program might not have installed correctly' after Configuration (config.exe) in Windows Vista.

v5.01 January 2008

Improved Editor: Zoom in up to 500%.
Fixed Editor: Zoom to Fit/Width when Scale is below 100%.
Fixed C#: class, partial class, inherited class.
Fixed XSLT: File load sometimes dropped 3 bytes from start of file.

v5.0 November 2007

New feature highlights

Editor lets you edit and draw flow charts manually.
Bulk jobs flowchart your programs in unattended mode. Run jobs from the DOS command line.
Save and load TIFF flow charts. Bulk save everything in a multi-page TIFF.

New and updated languages

ColdFusion flowcharting.
XSLT flowcharting.
Delphi flowcharting updated for Turbo Delphi 2006.

Improvements

Visio export runs in the background while you continue working on other charts.
Visio export minimizes crossing of Yes/No links from a decision diamond.
PowerPoint export adds all flow chart slides into the same presentation in Bulk flowchart.
Flow chart metrics added: number of shapes and links. Metrics are stored in .gif, .png and .tif files.
Option for how much comment text is included. Short code and full comments. No code, full comments.
Added recent files list in the File menu.
Improved UML symbols to cover UML2. Decision conditions now shown as «DecisionInput».
Improved support for multi-monitor computers.
Improved GIF and PNG file load speed.
Improved memory consumption during TGA file save.
Improved printing: Print in vector format via Editor.
Improved printing: Portrait and Landscape option in Preview.
Improved security: Visustin is now digitally signed by Aivosto Oy.

Improvements on character sets

Character set options: Define source encoding to load EBCDIC, UTF-7, UTF-8 or a different character set than current Windows defaults.
Improved support for non-Latin characters.
Improved support for DOS special characters such as line drawing and graphic control character (1-31).
Added support for UTF-32/UCS-4 encoded source files.

Language specific improvements

Improved COBOL: Large charts display considerably better. PERFORM jumps no longer linked. SECTION and paragraph boxes deleted.
Improved COBOL: EXIT PARAGRAPH and EXIT SECTION.
Improved Delphi: Support for compiler directives. Better support for classes and international characters. No error from asm blocks.

Fixes

Fixed UML: Previously centered text now left-aligned.
Fixed COBOL: Empty sentence (extra period) caused parser to stop.
Fixed COBOL: Line continuation.
Fixed Delphi: Hung when function statement was inside begin..end.
Fixed Fortran 90: #ifdef-#else-#endif.
Fixed Fortran: End-of-line comments after ELSE.
Fixed VB: On Local Error.
Fixed EMF/WMF load problem with large files.
Fixed PNG load error in certain locales, such as Japanese.
Fixed Overview panel popping up unintended.

Removed features

Removed options to control the chart size. A similar effect is available through the Scale command in Editor.
Removed Windows 95 compatibility. New features are not being built or tested under Windows 95.

Version 4

v4.03 February 2007

Added export to Visio 2007.
Added export to Word 2007.
Added export to PowerPoint 2007.
Improved Copy to Clipboard to use less memory.
Improved zoom out when free RAM is scarce.
Fixed option "Print in monochrome".
Fixed COBOL: DISPLAY..AT, ACCEPT..AT.
Fixed COBOL: READ..NEXT RECORD.
Fixed COBOL: READ..END, RETURN..END, SEARCH..END.

v4.02 January 2007

Improved Fortran: Support for preprocessor directives (fpp and cpp, #if..#endif).
Improved Fortran: Different file extensions for fixed and free format source files.

v4.01 November 2006

Fixed setup: DLL version problem "Setup cannot continue because some system files are out of date on your system".
Fixed Visio export: Error 0 or 457.
Fixed Python: Bug/jam with multiline """...""" style comments.

v4.0 November 2006

New feature highlights

UML Activity Diagrams as flowcharting style
PowerPoint export: create flow chart slide show.
Word export: transfer flow charts to .doc.
Visio export improved with a new Visustin-controlled layout and straight lines.

New and updated languages

Updated support: VB 2005, Visual C++ 2005, C# 2.0, T-SQL for SQL Server 2005 and Sybase Adaptive Server v15.
Assembler flowcharting (MASM, NASM, IAR/MSP430).
Clipper flowcharting.
LotusScript flowcharting.
PowerScript flowcharting.
PureBasic flowcharting.
Python flowcharting.
REALbasic flowcharting.
Visual FoxPro flowcharting.

Save file format additions

Save TGA, PCX, PPM and PGM image files. Ensure interoperability with imaging applications and Unix tools.
Save Word .doc files and PowerPoint .ppt files.
Save source code into GIF and PNG images (optional). Preserve your code with the flow chart. Restore lost code. Re-chart old images.
Bulk save several charts in one file: DCX image collection, GIF image collection, or MHT multi-image archive.

New features and options

Image viewer feature. Load and view old flow charts. Option to view the original source code too.
Flow chart metrics including cyclomatic complexity and decision density.
Option to show compiler directives as flow symbols (#if..#else). Selected languages only.
Option 'Truncate long lines' keeps chart size down.
Option 'No code' reveals program structure without displaying the code.
Option to load DOS and Mac code.
Command line options support printing.

Improvements

Improved layout. Chart shapes fine-tuned. Try-Catch blocks improved.
Improved large print-outs with page numbers.
Improved small print-outs by automatic centering on page.
Improved Find: Case sensitive search, Whole word search.
Improved C/C++: Support for digraphs <% %> <: :> %: %:%: in addition to the regular delimiters { } [ ] # ##.
Improved PL/SQL and Ada: Show comments in flow charts.
Improved Fortran: ENTRY statement emphasized. TAB line format supported.

Fixes

Fixed EMF save format: Default image size increased.
Fixed Fortran: Source lines containing TAB characters.
Fixed VB: Comment was not displayed if it was the last line processed.
Fixed VB: Next i, j was not charted correctly.
Fixed VB: IF x GOTO label syntax supported
Fixed VB/QB: Rem statement syntax fixed.
Fixed PHP: Parsing was very slow at times.
Fixed PL/SQL and Ada: Error #28 Out of stack space with very long FOR..LOOP.

Replaced feature

Visio 2002 .txt export file has been replaced by direct export. Visio export now works without the obsolete plaintext export file.

Licensing

Changes in license terms

Version 3

v3.11 May 2006

Added Show code size in Help menu.
Improved printing of the Help file.
Fixed QuickBASIC On..Gosub.
Fixed COBOL END-STRING.

v3.1 February 2006

Added support to flowchart from Project Analyzer v8.
Added to Reset to defaults in Options menu.
Plus small fixes and improvements.

v3.06 September 2005

Improved COBOL support for GOBACK, EJECT, SKIP1, SKIP2, SKIP3 and TITLE.
Fixed COBOL bug with GO TO inside SEARCH..WHEN.

v3.05 August 2005

Fixed Perl parser bug causing jam.
Fixed COBOL parser bug with PERFORM VARYING where Visustin ignored some statements.

v3.04 June 2005

Fixed Pascal/Delphi error #28 Out of stack space when code contained a syntax error.
Fixed Pascal/Delphi "empty flow chart" problem when keyword IMPLEMENTATION was in upper case.

v3.03 June 2005

Improved Visio export speed with large charts.
Fixed Pascal/Delphi hang on if..then statement lacking spaces around if or then. The same fix also for while, for, with, case and on statements.
Fixed Pascal/Delphi "empty flow chart" problem with certain files with an interface-implementation pair.
Fixed crash with Bulk flowchart, Select files dialog when previously used directory had been deleted.

v3.02 April 2005

Fixed Fortran crash with Run-time error '0'.
Fixed Fortran "DO <line>" blocks where 2 or more DO's used the same <line>.
Fixed zoom quality on Windows NT.
Fixed setup problem on Windows ME.

v3.01 March 2005

Added Tip of the day feature.
Improved zoom out when low on memory.
Fixed black icon and toolbar crash on Windows NT.
Fixed Division by zero in main screen.
Fixed link directions with Visio 2002 .txt file import. If you see this problem, replace old visus3.vst (dated January 19, 2005) with the current version in your Visio Solutions directory.

v3.0 February 2005

New feature highlights

Full file flowcharting for all languages. File|Open dialog.
Enhanced large chart support with zoom, overview and mouse wheel.
Bulk flowchart. Select several files and chart them in a batch. Requires Pro Edition.
Save as GIF, HTML+GIF and MHT files.
Visio export directly to Visio 2002 and 2003. Save as Visio drawing (*.vsd,*.vdx). Requires Pro Edition.
Include comments in flow charts (not available for PL/SQL, Ada or COBOL).

New languages

ASP
JSP
PHP
Fortran

Improvements for large system charting

All languages support full file flowcharting. No more copy & paste & delete declarations.
No fixed limitation on code size. Code exceeding 64 kB is supported.
Automated page positioning and empty page detection in multi-page print preview.

New options

Comment options to include comments and compiler directives in the charts (not available for PL/SQL, Ada or COBOL).
Color options for monochrome and full color charts.
Black & White printing option.

User interface enhancements

Redesigned main window with toolbar.
Zoom in & out.
Overview panel allows easy navigation of large charts.
Mouse shortcuts and mouse wheel support added.
Keyboard shortcuts added.
Define a hotkey to activate Visustin.
Associate Visustin with source code files.
Command line options allow you to pass a source filename as a parameter to Visustin.
Enhanced drag & drop support. Drop code over chart or toolbar buttons to flowchart immediately.
Find dialog.

Code improvements, bug fixes

Improved VB/VBA/VB.NET/QuickBASIC: full file analysis support.
Improved VB.NET: Visualization Property Get/Set accessors.
Improved C/C++, C#, Java and T-SQL: full file analysis support (including multi-procedure analysis).
Improved C/C++: Added support for abort, exit, _exit, _cexit, _c_exit.
Improved C/C++: Added support for __try, __finally, __except and __leave (Microsoft extension).
Improved C/C++: __asm statements and blocks are noticed, although not visualized (Microsoft extension).
Improved Java: "catch (Exception e)" catches all exceptions.
Improved Java: static initialization blocks.
Improved JavaScript: nested procedure analysis support.
Improved Pascal/Delphi: full file analysis support (including nested procedures).
Improved PL/SQL and Ada: full file analysis support (including nested procedures).
Improved Ada: Pragma shown as compiler directive.
Improved Perl: BEGIN and END subroutines. Main program continues after a sub. Support for goto.

Fixed VB.NET: Catch e As System.Exception catches all types of exceptions.
Fixed Ada: Support for loop and block identifiers.
Fixed JavaScript: break and continue were treated incorrectly.
Fixed Unindent for COBOL so that it won't mess up with fixed columns.
Fixed T-SQL parsing problems.
Fixed T-SQL: @end caused parsing to stop.

Fixed PostScript file creation for font names including spaces.

Plus lots of small undocumented code improvements and fixes.

Replaced features

Save as HTML with JPEG has been replaced by Save as HTML with GIF.

Licensing changes

New editions, licensing options and activation
License terms changed

Version 2

v2.01 August 2004

Added support for Visio 2000. Not guaranteed to work.
Updated PL/SQL to Oracle 10g. New literal syntax: q'!...!'.
Improved support for code with only LF or CR as the newline character.
Improved Visio export adding support for the compression options in the Options menu (Display all code, Compress continuous blocks, Shorten code, Minimal code).
Fixed PL/SQL: Parser problem with multiline literals.
Fixed COBOL: Parser problem with certain embedded keywords such as PERFORM 3000 TIMES vs. PERFORM 3000-TIMES.
Fixed Paste: Warning if pasting too much code.
Fixed Save as WMF: Overflow with large charts.
Fixed Print Preview zoom list: Duplicate values appeared.

v2.00 February 2004

Visustin v2 is a major new release that adds languages, options, save formats and a variety of improvements.

New features

New languages: Perl, T-SQL, PL/SQL and Ada.
Print Preview
Multi-procedure visualization is available for certain languages.
Options to control chart size and reduce large charts.
Save new file formats, including HTML, WMF, EMF, DOT.
Visio export

Improvements

Improved all languages: Code size is no longer limited to 32 kB.
Improved VB.NET: Catch e As Exception catches all possible exceptions.
Improved VB: Added support for If x Goto linenum (without keyword Then).
Improved QuickBASIC: Added support for DEF FN, EXIT FN, SYSTEM
Improved Save BMP file: The saved file is now considerably smaller thanks to RLE compression.
Improved keyboard navigation and shortcuts.
Drag & drop support added.
Hit F11 to get a full screen chart.
Improved font options by adding support for new fonts and providing a list of supported fonts.

Changes and fixes

Fix: Printing didn't always obey printer settings. It has been fully rewritten to support them.
Change: The visualization of several programming elements has changed to get more readable diagrams. The most notable changes are with multiway decisions (select, case, switch), exception handling blocks (catch, except) and iterations (for, foreach).
Fix VB/VB.NET: Single-line If..Then with several statements in the Then branch, as well as If..Then..Else structures nested on a single line, are now parsed correctly.
Fix C/C++: Syntax "case abc::def:" didn't produce a correct chart.
Fix COBOL: EXEC blocks were sometimes handled incorrectly.
Fix COBOL: DELIMITED BY SIZE was handled incorrectly.
Removal: The legend feature has been removed. It showed a list of available node types.

Version 1

v1.22 October 2003

Improved COBOL: Added support for fixed format, columns 7-72 (skips columns 73-).
Improved COBOL: Single quotation marks are supported ('...').
Improved VB/VB.NET: The line continuation character '_' is supported.
Improved C/C++, C#, Java: Preprocessor directives are removed before visualization.
Fix COBOL/BASIC: Unknown GOTO destinations are shown correctly.
Fix COBOL: PERFORM within EVALUATE now visualizes correctly.
Fix: Code size limited to 32 kB to prevent errors.

v1.21 April 2003

Added support for SyncLock blocks in VB.NET.
Fixed a bug with capital "E" in Pascal "Else" and "End".
Fixed a bug with VB.NET's Select without Case.

v1.20 March 2003

Added languages COBOL and Object Pascal / Delphi.
Added splitter bar between the code and graph controls.
Added Unindent feature in Edit menu.
Multiway selection of 6 or more cases is visualized on two lines to save horizontal space.
More indicative visualization for the BASIC Gosub statement.
Added support for the C# statements unsafe and fixed.
Fixed handling of Java/JavaScript statements break label and continue label.
Fixed handling of special symbols | and { } in rare cases.
Fixed crash on minimize.

v1.10 February 2003

Added 4 new languages: C/C++, C#, Java and JavaScript.
Added support for the following VB statements: On..Goto, On..Gosub, If cond Then linenum Else linenum.
Improved support for VB.NET structured error handling and added the Throw statement.

v1.00 February 2003

Initial release supporting Visual Basic and Visual Basic .NET.

©Aivosto OyVisustin Help