Install and uninstall

Instructions to install and uninstall Project Analyzer.

Installation instructions

Installation for VB 6.0 Installation for other systems (.NET, VBA)

If you have Visual Basic 6.0 installed, do this:

  1. Download Project Analyzer. Choose the file without the run-times, it's the smaller download option.
  2. Create a new directory.
  3. Unzip the downloaded file.
  4. Run project.exe and analyze your projects!

If you do not have Visual Basic 6.0 installed, do this:

  1. Download Project Analyzer. Choose the file with the run-time libraries, that is, proawdll.zip.
  2. Create a new directory.
  3. Unzip the downloaded file.
  4. Install the run-time libraries (file name ProA_VB60DLLs.zip):
    • Create yet another new directory and unzip the library package.
    • Run setup.exe. If the program asks to do this, reboot your machine and run continue.exe.
    • This step may require running as Administrator.
  5. Unzip the actual program files (file name proa.....zip).
  6. Run project.exe.

Quick start

Run Project Analyzer (project.exe). Choose Analyze in the File menu and select a .vbp, .vbproj, .vbdproj, .sln, .vbg, .ebp or .mak file to analyze. Notice that the demo analyzes a maximum of 10 source files at a time. If your project is larger, uncheck some files. Click the Analyze button and see the program do its job. You can stay relaxed, Project Analyzer won't change your original files.

After the installation

Project Analyzer is a stand-alone tool, not an add-in. It does not automatically install itself in your Start menu or on the Desktop. You can create a shortcut by dragging project.exe in the appropriate menu location.

Uninstallation

Licensed user: If you wish to reinstall on another computer, contact Aivosto for deactivation instructions before uninstallation. You may need to prove uninstallation if your installation count exceeds your license size.

To completely remove Project Analyzer from your system, follow these steps:

1. Delete saved report files
In the Options menu of Project Analyzer, select Report Options, Explore saved reports. Delete this directory.
Repeat for Project Metrics (mtxview.exe), if you used it. In the Report menu, select Explore saved reports. Delete this directory.
2. Remove file associations (optional)
Clear the file associations if you configured any. In the Options menu of Project Analyzer, select File associations. Uncheck all checkboxes in the dialog.
Repeat for VBA Plug (vbaplug.exe), if you used it. In the File menu, select File associations
3. Uninstall run-times (optional)
Uninstall Project Analyzer Run-time Libraries via Windows Control Panel, Add/Remove Program Files. If you don't see Project Analyzer Run-time Libraries in the uninstallation list, you didn't install them and uninstallation is not necessary either. — Uninstalling the run-times is not usually necessary, because many other VB6 applications will require the same libraries. The versions installed by Project Analyzer are maximally compatible with other applications.
4. Unregister WinGraphviz.dll (optional)
If you did not uninstall the run-times (step 3), you can manually unregister WinGraphviz.dll via regsvr32.exe /u "c:\project_analyzer_path\WinGraphviz.dll". This step is not important, you can skip it. Do not perform this step if you use Visustin on the same computer.
5. Unregister ProASM.dll (optional)
If you have enabled .NET assembly analysis, you can manually unregister ProASM.dll via regasm.exe /unregister proasm.dll. This step is not important, you can skip it. Regasm.exe is a utility from the .NET Framework.
6. Remove your Project Analyzer directory
Delete all the files in it.
7. Remove shortcuts
Delete any Start menu or Desktop shortcuts you may have created.

Visustin note. Both Project Analyzer and Visustin install WinGraphviz.dll. Uninstallation will remove it, which may cause Visustin to malfunction. After uninstalling Project Analyzer, run Visustin to verify it still creates a flow chart. If there is a problem with WinGraphviz.dll, Visustin will try to re-register it. Alternatively, run regsvr32.exe "C:\Program Files\Visustin\WinGraphviz.dll", possibly as Administrator.

Read more

System requirements

©Aivosto Oy - Project Analyzer Help Contents