Project Analyzer main window

Project Analyzer main window
Click in the window to jump to related help. Open Find Listings Constants and Enums Call trees References Design quality and Summary report Report options Super Project Analyzer Project Printer Project Graph Project NameCheck Enterprise Diagrams Project Metrics A. Project Tree B. Hypertext view C. Details panel
Main window areas
A. Project tree B. Hypertext view
C. Details panel

A. Project tree

The Project tree on the left lets you navigate your project(s). Right-click a file, module or procedure for a popup menu. Double-click a graphics file (.frx file or picture) to view it.


B. Hypertext view

Surf your code in the hypertext panel. Your code is automatically color-coded and hyperlinked by Project Analyzer. Click the highlighted words and icons:

You can fine-tune the hypertext view by selecting Hypertext options in the Options menu. You can configure the colors, the underlining of links, the strikethrough effect on dead code and toggle line numbering on/off.

C. Details panel

Detailed information about the currently selected piece of code is to be found at the bottom of the main window.

Details panel

Problems tab File tab Module tab Procedure tab
Problem detection related functionality. Read more Information on the selected physical file on your disk. Lines of code, file size and date. File use trees (dependencies). Information on the selected module, form, class, interface or structure. Lines of code and other metrics. Procedures, variables, constants, Types and Enums defined in the module. Controls of classic VB forms.

Often, a file contains just one module, but VB.NET and COM files can contain several modules. Right-click in the lists to move around the project and view cross-references.

Details on the currently selected procedure. Lines of code and other metrics. Parameters, local variables, constants. Call trees forwards and backwards.

If this tab is empty, select a procedure first. Even though you see a procedure in the hypertext view, you may not be browsing that procedure but rather the module it appears in.

Legend

Dead procedure icon Dead code. The red line means that the code is dead. See Terminology.
Dead code. Strikethrough also indicates dead code.
Exposed procedure icon Exposed code. The violet X means that the code is not used by the currently analyzed project(s). It can still be in use by another, unanalyzed project. The deadness status is thus unknown.
Informational problem iconWarning iconCritical problem iconThese problem icons indicate a problem found in code review. Left-click or right-click the icon for more information.

You can open a full legend of all the icons in the Help menu.

Copy to Clipboard

You can copy the currently visible code to the Clipboard by pressing Ctrl+C. Alternatively, select Copy in the Edit menu. To copy just a small snippet, select some code and press Ctrl+C. The code is copied both as plain text and formatted (RTF). You can paste the formatted text to a word processor for professional-looking instant documentation.

Copy as HTML. The Edit menu also contains the option to Copy as HTML. This command copies the code to the Clipboard as raw HTML. The HTML code contains your source in color-coded format just like in Project Analyzer, making it ideal for publishing code snippets on the web. Just paste the HTML code to an HTML file and you're done. Hyperlinks are not preserved this way. Use Project Printer to publish hyperlinked source as HTML.

You can optionally include line numbers in the Clipboard copy. Check the Linenums in copy setting in Hypertext options.

Export code

You can export your source code in a variety of file formats or print it on paper. Available formats include PDF, HTML, RTF, UTF-8 and plain text. For PDF export and printing, see their specific help topic.

The Export command in the File menu saves the current source code into a syntax-formatted document file as HTML, RTF, UTF-8 or plain text. HTML is ideal for publishing code snippets on the web. Both RTF and HTML are suitable for documenting your code with a professional look. Export always saves the currently viewed portion of code, meaning the current procedure, module or file. Select some lines to export just the selected lines.

If line numbers are currently visible, Export will save line numbers in the file as well. Toggle line numbering on/off by right-clicking the hypertext area and selecting Line numbering.

Character set support. The other export formats are Unicode aware, but plain text exports 8-bit Ansi text.

©Aivosto Oy - Project Analyzer Help Contents