Project Analyzer Help - Tips

Tip #1: Project Analyzer reads Visual Basic code written with versions 3.0 to 6.0 and VB.NET 2002-2013. It also supports VBA code via VBA Plug.

Tip #2: If you require a printed tutorial to Project Analyzer, print tutorial.pdf.

Tip #3: Dead code means inoperative code that you can remove. Project Analyzer can find the dead code in your program. Reliable dead code analysis requires that you analyze all the files of your entire program.

Tip #4: Too many problems in your code? You can choose which problem icons you want to appear. Configure your own problem filter via Problem Options. More

Tip #5: Project Analyzer can document your entire project or solution. Hit F6 and run Project Printer to create a project web site with full source code and reports. More

Tip #6: To see where a procedure, variable or class is being used, right-click it and select References. More

Tip #7: To diagram your program, use Enterprise Diagrams in the Enterprise menu. More

Tip #8: Call trees are a great instrument to understand how a program works. Project Analyzer creates both textual and graphical procedure call trees. Press F7 after having analyzed a project. More

Tip #9: There are hidden features in the hypertext code view. Right-click the links instead of left-clicking them!

Tip #10: You can make your code run faster. Learn the Optimization rules and fix the problems in your code. More

Tip #11: Project Analyzer supports VBA code analysis, but you need VBA Plug for that. Analyze Word, Excel, Access, PowerPoint or Visio code. More

Tip #12: Enforcing variable naming standards can be beneficial to your code. Press F8 to configure Project NameCheck. More

Tip #13: You can list constants via the Variables, constants and parameters window. Alternatively, use the Constants and Enums window. Both of these windows are in the View menu. More

Tip #14: Are you sure your classes well designed? Get the Non-cohesive classes report and then some Cohesion diagrams. More

Tip #15: To understand how other files access file X, use the References window in the View menu. Select <Any other file> as the source and <X> as the target file. More

Tip #16: You can get a class hierarchy diagram in Enterprise Diagrams. See the Enterprise menu. More

Tip #17: You can get all the reports in html, mht, pdf, rtf or csv format. See the Report options in the Options menu. More

Tip #18: To create flowcharts of VB code, try our Visustin. It can flowchart any VB functions to readable charts. More on the web

Tip #19: Metrics are a great way to find coding problems and measure the quality of a program. Project Metrics provides extensive metrics in the Enterprise Edition. More

Tip #20: Is your program a victim of copy & paste coding? Open the Enterprise menu for Find duplicate code. More

Tip #21: Find and remove duplicate constants with the Constants and Enums window. More

Tip #22: List user-defined data types in the Data types window (View menu). More

Tip #23: You can use our VB Watch to add reliable error handlers to your VB6 program automatically. Try VB Watch today! More on the web

Tip #24: To list all "As New MyClass" references, use the References window in the View menu. Select "Instantiate object" as the reference type. More

Tip #25: To visualize "As New MyClass" references, get the Instantiation tree. Press F7 to run Project Graph after having analyzed a project. More

Tip #26: If you need to repeatedly analyze a certain group of files, you can create a .lst file listing all the file names to open. Then you simply open the .lst file instead of the individual projects. More

Tip #27: Use macros to have Project Analyzer create reports for you while you go out for a lunch. Macros are available in the Enterprise Edition. More

Tip #28: The RW and FLOWS metrics tell you what the key variables are in your program. More

Tip #29: What exactly is cyclomatic complexity? Fan-in? LCOM4? Learn to use metrics! Read the help file. More

Tip #30: How to measure coding productivity and convince the boss? Read Metrics how-to to learn more. More

Tip #31: Project Analyzer Enterprise Edition can analyze binary library files as well. Just enable DLL analysis and select some binary libraries when you open your program for analysis. More

Tip #32: To diagram your VB program in Visio, try Enterprise Diagrams in the Enterprise menu. More

Tip #33: To automate Visio flowcharting, try our Visustin. It can convert VB to Visio flow diagrams. More on the web

Tip #34: Wish to analyze a program by right-clicking the project file in the Windows Explorer? Use File associations in the Options menu to associate Project Analyzer with your source files. More

Tip #35: How does this program really work? Read 'How Project Analyzer works' in the help file. More

Tip #36: To debug your VB6 application, try our VB Watch. More on the web

Tip #37: You can disable a certain problem icon from appearing ever again. You do this by writing specially formed Comment directives in your code. More

Tip #38: You can make your code self-documenting with the help of the Comment manual and its special comment syntax. More

Tip #39: Learn the hidden features of Project Analyzer. Right-click the list and call tree controls to list references, create reports and copy data to the clipboard.

Tip #40: You can find more ad hoc reports in the context menus. Right-click items in the lists and treeviews of Project Analyzer.

Tip #41: Project Analyzer sees inside your .frx files. Double-click a .frx file to view its contents. This feature also allows you to extract images from forms and save them to disk.

Tip #42: If your colleague's code looks incomprehensible, send him some Style suggestions from Project Analyzer. More

Tip #43: Document the user interface of your application. Get the Form show diagram. See Enterprise Diagrams, Enterprise menu. More

Tip #44: Keep your code reusable by minimizing circular file dependencies. File dependency analysis tells you more about the dependency structure. More

Tip #45: Where are the bottlenecks? Try our VB Watch to measure the run-time performance of your functions. More on the web

Tip #46: Project Analyzer helps you publish code snippets on the Web. Select Copy as HTML in the Edit menu.

©Aivosto Oy - Project Analyzer Help Contents