Visustin tips

Tip #1: Visustin converts source code to flow charts. Load or Copy&Paste some code in the window and press Draw.

Tip #2: For a quick overview flow chart, press the Birdseye button. This creates a less detailed chart and fits it in the available display area.

Tip #3: To edit flow charts, first load some code in Visustin, then press the Editor button. With Editor you can also draw flow charts manually. Plan your systems before coding them. Draw flow charts of anything else, such as organizational workflows. Editor requires Visustin Pro Edition. More info

Tip #4: Visustin can export flow diagrams to Microsoft Visio. If you have Visio installed on this computer, you can test it by choosing Export to Visio in the File menu. See the help file for sample diagrams. Visio export requires Visustin Pro Edition and Visio on the same machine. More info

Tip #5: Visustin can save flow charts in several image formats ready for your documentation or publishing on the web. You can view samples in the help file. More info

Tip #6: Saving and Visio export are disabled in the free demo version. To test these features, use our free evaluation service. Just send some source code to Aivosto (vbshop @ aivosto.com). We will save/export a chart for you.

Tip #7: Was the chart rotated 90 degrees? You can see this effect in the free demo version. The full version does not have this limitation.

Tip #8: You can print the flow charts as well. A large chart can be distributed over several sheets or you can squeeze it to a single page. (Printing is disabled in the free demo version.)

Tip #9: To flowchart a part of your code only, use the Structure tab. Alternatively, select the code lines you wish to chart and press Draw, Save or Print Preview.

Tip #10: Need to save large flow charts? Save as PDF. It's a great way to view flow charts. For viewing on the screen, save as 'PDF, single page' or 'PDF, multipage'. Choose 'PDF, printer pages' for a print-optimized PDF. More info

Tip #11: You can give flow charts to your colleague. Save the chart as PDF and send it. More info

Tip #12: Would you like to flowchart several source files in one run? This is possible with the Bulk charting feature. Press Ctrl+B to run it. Bulk charting requires Visustin Pro Edition. More info

Tip #13: Scroll the flow chart by holding Shift down and moving the mouse over the chart. More info

Tip #14: Press F9 to show or hide the small overview flow chart. It is useful for navigating big charts.

Tip #15: Press the numeric keypad keys to scroll the flow chart. Hold the Ctrl key down to scroll faster. More info

Tip #16: Zoom quickly: Hold Ctrl down and left-click the mouse to zoom in. Ctrl + Right-click to zoom out. To toggle different zoom levels, hold Ctrl down and click the mouse wheel (or the middle mouse button). You can also press Ctrl and scroll the mouse wheel up or down. More info

Tip #17: If the help file (visustin.chm) is not working correctly, Windows may have placed a block on it when you downloaded it. It's easy to fix. Right-click visustin.chm in Windows. Select Properties and press Unblock. Now it works.

Tip #18: Wish to flowchart by right-clicking a file in the Windows Explorer? Use File associations in the Options menu to associate Visustin with your source files. More info

Tip #19: Would you need Visustin to support other programming languages? Write to Aivosto! We do listen to user feedback. Check out our web site to see what possibilities there are to get your language added. More info online

Tip #20: If Visustin runs when logged in as Administrator but crashes when logged in as a regular user, there is a solution: Does the user account have write access to a drive root, say C:\? Visustin requires root access for its temporary files. Press More info for the instructions on solving this. More info

Tip #21: You can edit flow charts with either the Visustin Editor or Microsoft Visio. Press the Editor button to try the built-in flow chart editor. Both features require the Visustin Pro Edition. More info

Tip #22: Need more diagrams - other than just the regular flow charts? If you're coding with Visual Basic, VB.NET or VBA, try our Project Analyzer. It creates several high-level diagrams, including call trees and file dependency charts. More info online

Tip #23: To flowchart an entire program, use the Bulk charting feature. It lets you select any number of files to chart in one run. Bulk charting requires Visustin Pro Edition. More info

Tip #24: You can load flow charts back in Visustin. Just open any of the image files you saved.

Tip #25: Get a new style. Try 'Flow chart alternative style' in the Options menu. More info

Tip #26: Bulk charting can optionally save all the charts in a single file. Instead of multiple files, you get several pages in a single multi-image archive. More info

Tip #27: Wish to save or print the Birdseye flow chart? Visustin always saves or prints the full flow chart, not the Birdseye view. You get a Birdseye-style chart with the following settings in the Options menu: 'Minimal code', 'Hide comments'. More info

Tip #28: Flowchart pseudocode. Yes, you can do it. Just write pseudocode in your favorite programming language. As long as you follow the fundamental syntax of your language, Visustin will flowchart it. Try it! More info

Tip #29: Quickly document your important routines. Export your charts to MS Word. See the Export command in the File menu. You can also save a .doc file via the Save command. More info

Tip #30: If you prefer UML, Visustin can create Activity Diagram style flow charts for you. Select the appropriate setting in the Options menu.

Tip #31: If you wonder what the different flow chart symbols are, check out the Symbols command in the Help menu. More info

Tip #32: Special characters not displaying correctly? You may need to select a better font and maybe also adjust the Source encoding or Font script settings. More info

Tip #33: You can adjust page breaks in the Print Preview window. Select a size and press Redraw. More info

Tip #34: If you have questions about Visustin, we at Aivosto will be happy to help you out. You can also check out the FAQ in the help file. More info

Tip #35: Are large charts slow on your machine? The help file provides lots of instructions on how to make large charts faster. More info

Tip #36: To flowchart each procedure individually, use Bulk flowcharting. Select the 'Split files by Structure' checkbox. Feature requires Pro Edition. More info

Tip #37: To create flow chart web pages with a menu that lists all your procedures, use Bulk flowcharting. Select the 'Structure menu' checkbox. Feature requires Pro Edition. More info

Tip #38: You can run Visustin from a batch file with the Bulk charting feature. First run Bulk charting and define a job. You can then have Visustin process the job at a later time. Feature requires Pro Edition. More info

Tip #39: Visustin helps you understand code written in a strange language. Reviewing the code visually helps understand the logic behind a strange function - even if you aren't fluent in that language. This way a C++ developer can read VB and a Delphi developer can read Python.

©Aivosto Oy Visustin Help